请选择 进入手机版 | 继续访问电脑版

第一课堂

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 3458|回复: 0

Issue installing Microsoft Visual C++ (x64) prerequisite

[复制链接]
发表于 2018-5-28 14:32:41 | 显示全部楼层 |阅读模式
Hello,

I am using Advanced Installer 14.8 on a Windows Server 2008 R2 Standard (64 bit) machine.As part of my installer I need to install BOTH the 2012 and 2013 64 bit Microsoft Visual C++ Redistributable. Under Feature-based I have the prerequisites listed in the following order: 2013, 2012. (Note the order!)When I run the installer on a machine that DOES NOT HAVE EITHER of these 2 prerequisites I encounter the following error:Warning 4154. Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030 prerequisite was not correctly installed. Continue installation.... ?
(C++ 2013 gets installed!)
However, if I change the order of the prerequisites (2012, 2013), I encounter the follower error:
Warning 4154. Microsoft Visual C++ 2013 Redistributable (x64) - 12.0.30501 prerequisite was not correctly installed. Continue installation.... ?
(C++ 2012 gets installed!)
IMPORTANT... Depending on the order that the prerequisites are listed under Feature-base I get a different error!!!
The prerequisites are listed under Feature-based. I am using the following conditions to determine if the prerequisites are installed:
For C++ 2013 - Registry Key Exists : HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Dependencies\{050d4fc8-5d48-4b8f-8972-47c82c46020f}
For C++ 2012 - Registry Key Exists : HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Dependencies\{ca67548a-5ebe-413a-b50c-4b9ceb6d66c6}
Each prerequisite is configured to install if at least one condition is false AND to Use 64-bit locations when evaluating conditions on a 64-bit machine. I am running the installer on a Windows 7 64 bit machine!!!Each prerequisite has the following Install Command Line parameter settings:
Full UI: /q /norestart
Basic UI: /q /norestart
Silent (no UI): /q /norestart
I am providing the installer with the prerequisite files.
If I manually installed BOTH the 2012 and 2013 C++ Restributuables (x64) and then run the installer, the installer completes with no errors!
Any suggestions on how I can get around this issue would be greatly appreciated!


Please help

I didn't find the right solution from the internet.

References:
https://www.advancedinstaller.com/forums/viewtopic.php?t=35430
Motion graphics video animation company

Thank you


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|第一课堂 ( 粤ICP备10228254号 )

GMT+8, 2021-3-5 02:18 , Processed in 0.009230 second(s), 9 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表